Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Kein Zugriff auf Network Shares

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 2
Registriert: 14.03.2009, 17:14

Kein Zugriff auf Network Shares

Beitragvon p_dot » 14.03.2009, 17:38

Hallo,
hab VMWare Player 2.5.1 unter Ubuntu Hardy Heron. Darunter läuft ein XP-Gastsystem (Netzwerk=NAT). Wenn ich diesen Gast mit einer Network Boot Disk starte (d.h. eigentlich Win98-DOS) dann liefert ein NET USE auf Network shares (Samba/SMB) immer Error 53 (The computer name specified in the network path cannot be located). Auch bei Angabe der IP-Adresse \\xxx.xxxx.xxxx.xxx\sharename ist es das gleiche. Ein PING auf diese IP-Adresse funktioniert aber reibungslos. Das share liegt NICHT auf dem Ubuntu-Host sondern ist ein eigener Rechner (NAS).

Ich nehme daher an das Problem liegt in der VM-Konfiguration am Ubuntu-Host, oder ev. auch Gast. Vom Ubuntu-Host selbst kann ich nämlich problemlos auf dieses Share zugreifen.

Ich seh' wahrscheinlich den Wald vor lauten Bäumen nicht mehr, such jetzt schon tagelang ohne Erfolg... was kann das sein?

Hier die VMX:
#!/usr/bin/vmplayer
.encoding = "UTF-8"

# Filename: My_VMX.vmx
# Generated 2008-12-28;13:59:19 by EasyVMX!
# http://www.easyvmx.com

# This is a Workstation 5 or 5.5 config file
# It can be used with Player
config.version = "8"
virtualHW.version = "4"

# Selected operating system for your virtual machine
guestOS = "winxppro"

# displayName is your own name for the virtual machine
displayName = "My_VMX"

# These fields are free text description fields
annotation = "My_VMX (VM@DUCHAMP for administrative purposes)."
guestinfo.vmware.product.long = "My_VMX - WinXP"
guestinfo.vmware.product.url = "http://www.easyvmx.com/"
guestinfo.vmware.product.class = "virtual machine"

# Number of virtual CPUs. Your virtual machine will not
# work if this number is higher than the number of your physical CPUs
numvcpus = "1"

# Memory size and other memory settings
memsize = "768"
MemAllowAutoScaleDown = "FALSE"
MemTrimRate = "-1"

# Unique ID for the virtual machine will be created
uuid.action = "create"

# Remind to install VMware Tools
# This setting has no effect in VMware Player
tools.remindInstall = "FALSE"

# Startup hints interfers with automatic startup of a virtual machine
# This setting has no effect in VMware Player
hints.hideAll = "TRUE"

# Enable time synchronization between computer
# and virtual machine
tools.syncTime = "TRUE"

# USB settings
# This config activates USB
usb.present = "TRUE"
usb.generic.autoconnect = "FALSE"

# First serial port, physical COM1 is available
serial0.present = "TRUE"
serial0.fileName = "Auto Detect"
serial0.autodetect = "TRUE"
serial0.hardwareFlowControl = "TRUE"

# Optional second serial port, physical COM2 is not available
serial1.present = "FALSE"

# First parallell port, physical LPT1 is available
parallel0.present = "TRUE"
parallel0.fileName = "Auto Detect"
parallel0.autodetect = "TRUE"
parallel0.bidirectional = "TRUE"

# Sound settings
sound.present = "TRUE"
sound.virtualdev = "es1371"

# Logging
# This config activates logging, and keeps last log
logging = "TRUE"
log.fileName = "My_VMX.log"
log.append = "TRUE"
log.keepOld = "3"

# These settings decides interaction between your
# computer and the virtual machine
isolation.tools.hgfs.disable = "FALSE"
isolation.tools.dnd.disable = "FALSE"
isolation.tools.copy.enable = "TRUE"
isolation.tools.paste.enabled = "TRUE"

# First network interface card
ethernet0.present = "TRUE"
# ethernet0.virtualDev = "e1000"
ethernet0.virtualDev = "vlance"
ethernet0.connectionType = "nat"
ethernet0.addressType = "generated"
ethernet0.generatedAddressOffset = "0"

# Settings for physical floppy drive
floppy0.present = "TRUE"
floppy0.startConnected = "TRUE"
floppy0.autodetect = "FALSE"

# Settings for physical CDROM drive
ide1:0.present = "TRUE"
ide1:0.deviceType = "cdrom-raw"
ide1:0.startConnected = "TRUE"
ide1:0.fileName = "auto detect"
ide1:0.autodetect = "TRUE"

# First IDE disk, size 8Gb
ide0:0.present = "TRUE"
ide0:0.fileName = "My_VMX.vmdk"
ide0:0.mode = "persistent"
ide0:0.startConnected = "TRUE"
ide0:0.writeThrough = "TRUE"

# END OF EasyVMX! CONFIG

# added to slow down booting process (for easy access of BIOS):
# see http://communities.vmware.com/docs/DOC-1201
bios.bootDelay = "4000"

extendedConfigFile = "My_VMX (VM).vmxf"

floppy0.fileName = "/dev/sdb"
virtualHW.productCompatibility = "hosted"
tools.upgrade.policy = "manual"

checkpoint.vmState = ""
ethernet0.generatedAddress = "00:0c:29:eb:23:96"
uuid.location = "56 4d 22 54 de 77 a5 2c-e7 85 d7 21 20 eb 23 96"
uuid.bios = "56 4d 22 54 de 77 a5 2c-e7 85 d7 21 20 eb 23 96"
ide0:0.redo = ""
vmotion.checkpointFBSize = "16777216"
parallel0.startConnected = "FALSE"
serial0.startConnected = "FALSE"

ide0:1.redo = ""

usb.autoConnect.device0 = ""
_____________________________________________________________________

Und hier die aktuelle ifconfig (Ubuntu-Host):
eth0 Link encap:Ethernet HWaddr 00:21:70:8a:8e:df
inet addr:172.17.0.17 Bcast:172.17.0.255 Mask:255.255.255.0
inet6 addr: fe80::221:70ff:fe8a:8edf/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:36509 errors:0 dropped:0 overruns:0 frame:0
TX packets:27428 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:33456375 (33.4 MB) TX bytes:4136659 (4.1 MB)
Interrupt:17

eth1 Link encap:Ethernet HWaddr 00:23:4d:3e:8c:72
inet6 addr: fe80::223:4dff:fe3e:8c72/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:17 Base address:0xc000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:8 errors:0 dropped:0 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:648 (648.0 B) TX bytes:648 (648.0 B)

vmnet1 Link encap:Ethernet HWaddr 00:50:56:c0:00:01
inet addr:192.168.230.1 Bcast:192.168.230.255 Mask:255.255.255.0
inet6 addr: fe80::250:56ff:fec0:1/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:116 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

vmnet8 Link encap:Ethernet HWaddr 00:50:56:c0:00:08
inet addr:172.16.218.1 Bcast:172.16.218.255 Mask:255.255.255.0
inet6 addr: fe80::250:56ff:fec0:8/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:373 errors:0 dropped:0 overruns:0 frame:0
TX packets:270 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


Bin dankbar für jedwede Idee.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 14.03.2009, 18:03

warum verwendest du denn NAT wenn die VM auf das externe Netzwerk zugreifen soll ?

Member
Beiträge: 2
Registriert: 14.03.2009, 17:14

Beitragvon p_dot » 14.03.2009, 19:08

Hallo Ulli,
warum sollte ich nicht NAT verwenden? Ich will ja nur "hinaus". Es funktioniert ja auch aus dem VM Gast wenn ich diesen mitr XP boote statt mit DOS (wenn auch nur mit IP-Adresse). Auch Firefox usw usf funktioniert reibungslos über NAT.

Was ich nicht begreife ist warum der PING funktioniert aber das NET USE nicht. Aber Moment - vielleicht ist es ja gerade ein DNS Problem?!? Und NET USE unter DOS unterstützt vielleicht keine IP-Adressierung, sonder nur über den Namen?!? Dann frag' ich mich allerdings warum es unter dem Host in Ubuntu funktioniert...

Wenn es ein DNS Problem ist, wo muß ich ansetzen um das zu lösen?
Oder aber, wenn NAT das Problem ist, wie setz' ich" Bridged" richtig auf? Ich hab' nämlich Bridged schon kurz probiert (einfach umstellen über Menü Devices - Network Adapter) aber ohne Erfolg.

p_dot


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast