Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Kein Sound bei XP-Gast auf Ubuntu-Host

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 4
Registriert: 16.01.2009, 03:23

Kein Sound bei XP-Gast auf Ubuntu-Host

Beitragvon hakoe » 16.01.2009, 03:49

Hallo Ihr virtuellen Freunde, die Menschheit hat ein neues Problem!
Host: Ubuntu 8.04.1; Gast: Original XP Home SP3 (Installiert in einer leeren VM)
Die Verbindung zur Sountkarte wird abgelehnt mit dem Hinweis

Failed to open sound device /dev/dsp2: no such file or directory
Failed to connect virtual device sound

Sound im Host ist ok.
Im Geräte-Manager des Gastes gibt es auch nichts Auffälliges
Die Sound-Parameter in der .vmx sind:
sound.present = "TRUE"
sound.fileName = "-1"
sound.autodetect = "TRUE"

Wer kann helfen ?

Experte
Beiträge: 1188
Registriert: 08.11.2005, 13:08
Wohnort: bei Berlin

Beitragvon e-e-e » 16.01.2009, 07:22

Hallo,

ich gehe mal davon aus, dass Dein Sound-Device auf dem Host wirklich /dev/dsp2 ist, dann trage doch mal statt der -1 diesen Pfad ein, und schon sollte es klappen. Die Zeile sound.autodetect = "TRUE" solltest Du dann noch auskommentieren.

Member
Beiträge: 4
Registriert: 16.01.2009, 03:23

/dev/dsp2 als Parameter statt -1

Beitragvon hakoe » 16.01.2009, 09:23

Leider nicht die Lösung. Die vorgeschlagene Lösung führt dazu, das die VM beim Start als schon besetzt gemeldet wird. Der Gast muß nun neu installiert werden.

Aber danke für die Hilfe. Man wird ja nicht dümmer beim Ausprobieren.

Member
Beiträge: 4
Registriert: 16.01.2009, 03:23

Fehlersuche geht weiter

Beitragvon hakoe » 16.01.2009, 09:59

Ich habe inzwischen mal in den Tiefen von VMware (/etc/vmware, /usr/lib/vmware ...)
nach dem Ausdruck /dev/dsp2 gesucht.
Nichts gefunden!
Wie also kommt der Knaller dazu, nach einem Sound-Device /dev/dsp2 zu suchen??

Experte
Beiträge: 1188
Registriert: 08.11.2005, 13:08
Wohnort: bei Berlin

Beitragvon e-e-e » 16.01.2009, 12:14

Hallo,

mein Sound-Device ist /dev/dsp. Vielleicht solltest Du die 2 mal weglassen.

Member
Beiträge: 4
Registriert: 16.01.2009, 03:23

Kein Sound

Beitragvon hakoe » 17.01.2009, 07:52

Hallo Ronny,
das /dev/dsp2 kann ich nicht eingeben (siehe oben)
Ich habe jetzt mal auf dem gleichen PC einen VMware-Server2 installiert und
dann eine neue VM für XP erstellt. Diese enthält gleich gar keine Einträge in
der .vmx für virtuellen Sound. Füge ich diese dann ein, erscheint wieder die
Fehlermeldung.
Im Wirtsbetriebssystem Ubuntu 8.04.1 funktioniert der Sound jedoch in allen
Anwendungen (Skype, Video, TV usw).
Was tun ?


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast