Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Kein Sound im Gast Win XP

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 5
Registriert: 05.07.2008, 21:45

Kein Sound im Gast Win XP

Beitragvon s1640066 » 05.07.2008, 22:04

Hallo Leute ich habe mich so ziemlich duch viele Foren durchgelsen, aber nicht ganz fündig geworden. Ich hoffe jemand kann mir helfen...
also zum Problem:
Wirt-System: Opensuse 10.2 mit Gnome
Virtualisierung durch Vmware-player2.0.2
Gast-System: Windows XP Pro.
Das Problem ist, dass der Sound nicht läuft. Eine Meldung kommt, wenn ich versuche z.B. MP3 zu spielen, dass die Soundkarte nicht verbunden werden kann. Wahrscheinlich, weil sie durch andere Anwendung im Wirtsystem besetzt ist. Irgendwas kommt immer dass dev/dsp busy ist. . Durch einen anderen Threead bin ich schlauer geworden, dass man der Vmware die Verwendung von alsa-mixer zuweisunen soll, was die gemeinsame Nutzung des Gastes und des Wirtes erlauben soll. leider war die Beschreibung für KDE!! Hier dann meine Frage (endlich!!!) ...... Wie kann ich diese Zuweisung in meinem Wirtsystem anrichten???
Dateianhänge
fehlermedlung_soun.jpg
fehlermedlung_soun.jpg (9.55 KiB) 44 mal betrachtet

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 13.07.2008, 15:30

Hi,
geht der Sound überhaupt? Z.B. kann realplayer was spielen?
Martin

Member
Beiträge: 5
Registriert: 05.07.2008, 21:45

Beitragvon s1640066 » 13.07.2008, 19:38

Nein, keiner meiner vorhandenen Player gibt Sound aus. Auch bei Einstellungen/audio steht... Kein Gerät verfügbar!

Guru
Beiträge: 2237
Registriert: 21.09.2005, 00:12

Beitragvon stefan.becker » 13.07.2008, 20:36

Warum kommst du auf den Gedanken, so was im Gast abzuspielen?

Bis auf DRM-Müll kann Linux doch alles abspielen.

Member
Beiträge: 3
Registriert: 12.07.2008, 11:32

Beitragvon hans5 » 13.07.2008, 20:42

Hi,

Du hast bestimmt dran gedacht, aber sind die Einträge für sound.*** in der vmx-Datei vorhanden?

Gruß
Hans5

Member
Beiträge: 5
Registriert: 05.07.2008, 21:45

Beitragvon s1640066 » 13.07.2008, 23:59

ich weiß nicht... aber ich poste dir mal meine vmx...

#!/usr/bin/vmware
config.version = "8"
virtualHW.version = "4"
memsize = "512"
MemAllowAutoScaleDown = "FALSE"
MemTrimRate = "-1"
displayName = "vm_winxp"
guestOS = "winxppro"
tools.remindInstall = "FALSE"
sound.present = "TRUE"
sound.virtualDev = "sb16"
sound.filename = "-1"
sound.autodetect = "TRUE"
usb.present = "TRUE"
ethernet0.present = "TRUE"
ethernet0.addressType = "generated"
ethernet0.connectionType = "bridged"
ethernet1.present = "TRUE"
ethernet1.addressType = "generated"
ethernet1.connectionType = "bridged"
scsi0:0.present = "TRUE"
scsi0:0.fileName = "vm_winxp.vmdk"
ide0:0.present = "TRUE"
ide0:0.autodetect = "TRUE"
ide0:0.filename = "auto detect"
ide0:0.deviceType = "atapi-cdrom"
scsi0.present = "TRUE"
scsi0.virtualDev = "buslogic"
buslogic.noDriver = "FALSE"

floppy0.fileName = "/dev/fd0"
sound.deviceNr = "-1"
sound.device = "/dev/dsp"
extendedConfigFile = "vm_winxp.vmxf"
virtualHW.productCompatibility = "hosted"
tools.upgrade.policy = "manual"

ethernet0.generatedAddress = "00:0c:29:b9:95:c1"
ethernet1.generatedAddress = "00:0c:29:b9:95:cb"
uuid.location = "56 4d 9f 9a 1a aa 90 29-87 7e 44 7c c9 b9 95 c1"
uuid.bios = "56 4d 9f 9a 1a aa 90 29-87 7e 44 7c c9 b9 95 c1"
scsi0:0.redo = ""
checkpoint.vmState = "vm_winxp.vmss"
ethernet0.generatedAddressOffset = "0"
ethernet1.generatedAddressOffset = "10"

isolation.tools.hgfs.disable = "FALSE"

usb.autoConnect.device0 = ""

tools.syncTime = "TRUE"

usb.autoConnect.device1 = ""

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 14.07.2008, 17:41

s1640066 hat geschrieben:Nein, keiner meiner vorhandenen Player gibt Sound aus. Auch bei Einstellungen/audio steht... Kein Gerät verfügbar!


OK, dann ist das kein VMWare Fehler. Versuch erstmal den Sound auf dem System klar zu kriegen. Linux tut sich da bisweilen schwer. In den einschlägigen Linux-Foren findest Du bestimmt Hilfe.
Martin

Member
Beiträge: 5
Registriert: 05.07.2008, 21:45

Beitragvon s1640066 » 14.07.2008, 20:31

ich glaube nicht, dass es am Gast-System (win xp) liegt. Die Fehlermeldung berichtet, dass /dev/desp "busy" also besetzt ist. Also wird das Gerät vom Wirt (opensuse) besetzt und vmplayer kann den Sound-Mixer nicht nutzen.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast