Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Maus sitzt unten rechts fest (PCLinuxOS auf Win2000)

Hilfe bei Problemen mit der Installation und Benutzung des VMware Player.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 2
Registriert: 11.04.2008, 11:50

Maus sitzt unten rechts fest (PCLinuxOS auf Win2000)

Beitragvon skfink » 11.04.2008, 11:57

Hallo,
ich habe im Player eine PCLinuxOS Installation unter Windows 2000. Eine Weile lang hat auch alles sehr gut funktioniert, bis einmal in der VM nichts mehr ging, nach mehreren Minuten habe ich dann einen Reset durchgeführt. Seit dem Hängt die Maus in der unteren rechten Ecke und ist von dort nicht weg zu bewegen. Wenn ich versuche mit der Tastatur weiter zu kommen geht das auch nur bedingt. Tab und Enter etc gehn auch, wenn ich in die Konsole was eintippen will, kommt nichts an, bzw erst wenn ich wieder Enter drücke. Ich weiss nun nicht ob es ein Problem bei der VM ist oder bei PCLinuxOS. Leider bin ich auch nicht gerade ein Linux-Experte, weswegen ich ziemlich ratlos bin. Würde die Installation aber ganz gerne retten wenn Möglich, da doch einiges an Arbeit drin steckt

mfg

Experte
Beiträge: 1425
Registriert: 11.08.2004, 17:08
Wohnort: Paderborn

Beitragvon MSueper » 11.04.2008, 22:25

Hi,
log Dich mal per Putty und ssh auf Deine VM ein und guck in die /etc/X11/xorg.conf rein.
Da sollen Einträge dieser Art stehen:

Code: Alles auswählen

Section "InputDevice"
  Identifier "Configured Mouse"
  Driver "mouse"
  Option "CorePointer"
  Option "Device" "/dev/input/mice"
  Option "Protocol" "imps/2"
  Option "ZAxisMapping" "4 5"
  Option "Emulate3Buttons" "true"
EndSection


Die Einstellung /dev/input/mice ist hier wichtig. Die Einstellung für die Tastatur sollte so (ähnlich) aussehen.

Code: Alles auswählen

Section "InputDevice"
  Identifier "Keyboard"
  Driver "Keyboard"
  Option "XKbModel" "pc105"
  Option "XKbRules" "xfree86"
  Option "XKbLayout" "de"
EndSection


WICHTIG: mach eine Kopie von der xorg.conf, bevor Du was änderst! Dein System wird nicht mehr mit GUI starten, wenn Du hier was falscht machst.
Martin

Member
Beiträge: 2
Registriert: 11.04.2008, 11:50

Beitragvon skfink » 14.04.2008, 11:05

so jetzt bin ich endlich dazu gekommen.
Also putty kannte ich nicht und weiss auch nicht wie ich was damit machen soll, aber ich bin einfach auf init 3 zurück gegangen und hab mir dann die besagte Datei angesehn, da steht folgendes drin für die Maus:

Code: Alles auswählen

Identifier "Mouse1"
Driver "vmmouse"
Option "Protocol" "ps/2"
Option "Device" "/dev/mouse"


und für das Keyboard:

Code: Alles auswählen

Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "de(nodeadkeys)"
Option "XkbOptions" "compose:rwin"

Obwohl das Keyboard unter der Console ja gut funktioniert, nur im Grafikmodus hats teilweise Probleme gegeben. Aber für das init 3 hats auch da noch gereicht.


Zurück zu „VMware Player“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast