Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Postgres Problem in VCSA 6.0

Virtualisierungsmanagement, Servermanagement.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 109
Registriert: 19.04.2015, 09:25

Postgres Problem in VCSA 6.0

Beitragvon Chrismvm » 03.01.2017, 10:31

Hallo,

ich habe hier auf meinem vcenter immer diese Meldungen. Wie komme ich da weiter und kann die Ursache beheben.

Bildschirmfoto 2017-01-03 um 10.17.42.png


Bildschirmfoto 2017-01-03 um 10.15.03.png
Bildschirmfoto 2017-01-03 um 10.15.03.png (27.99 KiB) 362 mal betrachtet


Wenn ich einen ps -ef | grep postgres absetze bekomme ich diese Liste. Wie ich finde sind hier viele Prozesse als "idle"

Code: Alles auswählen

root     10469     1  0  2016 ?        07:18:43 /bin/sh /usr/bin/vmware-watchdog -b /storage/db/vpostgres/postmaster.pid -u 300 -q 2 -s vmware-vpostgres su
1011     10492     1  0  2016 ?        00:03:20 /opt/vmware/vpostgres/9.3/bin/postgres -D /storage/db/vpostgres
1011     10541 10492  0  2016 ?        00:00:00 postgres: logger process
1011     10709 10492  0  2016 ?        00:08:49 postgres: checkpointer process
1011     10710 10492  0  2016 ?        00:01:17 postgres: writer process
1011     10711 10492  0  2016 ?        00:01:47 postgres: wal writer process
1011     10712 10492  0  2016 ?        00:03:13 postgres: autovacuum launcher process
1011     10713 10492  0  2016 ?        00:12:03 postgres: stats collector process
1011     10714 10492  0  2016 ?        00:04:23 postgres: bgworker: health_status_worker
1011     11217 10492  0  2016 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38405) idle
1011     11218 10492  0  2016 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38406) idle
1011     11595 10492  0  2016 ?        00:01:07 postgres: vc VCDB 127.0.0.1(38440) idle
1011     17506 10492  0  2016 ?        00:00:43 postgres: vc VCDB 127.0.0.1(39032) idle
1011     18364 10492  0  2016 ?        00:00:45 postgres: vc VCDB 127.0.0.1(39035) idle
1011     18408 10492  0  2016 ?        00:00:50 postgres: vc VCDB 127.0.0.1(39036) idle
root     18491 18247  0 09:18 pts/1    00:00:00 grep postgres
1011     18580 10492  0  2016 ?        00:01:44 postgres: vc VCDB 127.0.0.1(39042) idle in transaction
1011     18592 10492  0  2016 ?        00:01:06 postgres: vc VCDB 127.0.0.1(39043) idle in transaction
1011     19415 10492  0  2016 ?        00:00:44 postgres: vc VCDB 127.0.0.1(39144) idle
1011     19417 10492  0  2016 ?        00:00:44 postgres: vc VCDB 127.0.0.1(39145) idle
1011     19418 10492  0  2016 ?        00:00:49 postgres: vc VCDB 127.0.0.1(39146) idle
1011     19420 10492  0  2016 ?        00:01:27 postgres: vc VCDB 127.0.0.1(39148) idle in transaction
1011     19427 10492  0  2016 ?        00:01:26 postgres: vc VCDB 127.0.0.1(39154) idle in transaction
1011     21452 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38565) idle
1011     21454 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38566) idle
1011     21455 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38567) idle
1011     21457 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38568) idle
1011     21458 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38569) idle
1011     21459 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38570) idle
1011     21461 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38571) idle
1011     21464 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38572) idle
1011     21466 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38573) idle
1011     21468 10492  0 07:00 ?        00:00:00 postgres: vc VCDB 127.0.0.1(38574) idle
1011     26466 10492  0  2016 ?        00:00:00 postgres: vc VCDB 127.0.0.1(39640) idle


Oh, bevor ich es vergesse ich habe eine VCSA 6.0 auf Linux laufen.


Gruß
Chris

Experte
Beiträge: 1113
Registriert: 04.10.2011, 14:06

Re: Postgres Problem in VCSA 6.0

Beitragvon JustMe » 03.01.2017, 12:00

Hi Chris,

zwei Sachen vorneweg:
- Client auf ENGLISH umstellen
- GENAUE vCenter Server Version inkl. Build waere toll

Und dann zum Problem:
die Screenshots sagen leider noch nicht allzuviel.
Aber ausgehend von VMware's KBs 2112606 und 2058187 waere wohl die Datei /etc/vmware-sca/health/vmware-postgres-health-status.xml zu untersuchen. Evtl. gibt's da tieferliegende Hinweise.

Member
Beiträge: 109
Registriert: 19.04.2015, 09:25

Re: Postgres Problem in VCSA 6.0

Beitragvon Chrismvm » 03.01.2017, 13:20

Tja, diese Screens sind aber derzeit das einzige was ich so habe. :?
Leider. Auf English wollte ich nicht unbedingt umschalten, bringt ja auch nicht wirklich was, oder?

Die genaue Version ist VCSA-6.0.0.20100-4632154-patch-FF

Werde mir mal die vmware-postgres-health-status.xml ansehen.

Experte
Beiträge: 1113
Registriert: 04.10.2011, 14:06

Re: Postgres Problem in VCSA 6.0

Beitragvon JustMe » 03.01.2017, 13:27

Den Client auf Englisch umzustellen bringt wie schon haeufig erwaehnt schon etwas, naemlich die Moeglichkeit, beim Suchen/"Googlen" nach den Fehlermeldungen viel mehr Treffer zu erzielen... :idea:

Member
Beiträge: 109
Registriert: 19.04.2015, 09:25

Re: Postgres Problem in VCSA 6.0

Beitragvon Chrismvm » 03.01.2017, 13:32

die XML zeigt folgendes, hier verstehe ich aber nicht ganz warum GREEN angegeben ist und dennoch eine Meldung im WebGUI erscheint.

Code: Alles auswählen

<?xml version="1.0" encoding="UTF-8" standalone="yes"?><healthStatus schemaVersion="1.0" xmlns="http://www.vmware.com/cis/cm/common/jaxb/healthstat
us"><status>GREEN</status><message messageKey="cis.vpg.health.healthy" defaultMessage="VMware Postgres service is healthy."></message><expiration>2
017-01-03T12:23:04.000Z</expiration></healthStatus>

Experte
Beiträge: 1113
Registriert: 04.10.2011, 14:06

Re: Postgres Problem in VCSA 6.0

Beitragvon JustMe » 03.01.2017, 13:54

Das duerfte damit zusammenhaengen, dass der Status des Dienstes um 12:23 Uhr (UTC) tatsaechlich "green" war, aber um 2:28 Uhr in der Nacht eben nicht. Wenn ein Status wieder auf OK wechselt, wird i.A. kein Alarm getriggert.

Du hast selbstverstaendlich recht; in einer .xml-Datei wird man nicht viel Log-Info finden. Mein Fehler. Schau' doch mal unter /var/log in der Appliance, ob's da nicht irgendwelche Dateien mit Bezug zu vPostgres gibt. Du kannst auch mal alle Dateien nach dem Text der Meldung durch'grep'en (da waere es andererseits besser, den ENGLISCHEN Text zu haben ;-)), um zu ermitteln, WO man was dazu findet, und dann die "Umgebung" in der ermittelten Logdatei nach weiteren Hinweisen zu durchforsten.

Leider kann ich's momentan nicht detaillierter ausfuehren; mir fehlt die entsprechende Infrastructure.

Member
Beiträge: 109
Registriert: 19.04.2015, 09:25

Re: Postgres Problem in VCSA 6.0

Beitragvon Chrismvm » 03.01.2017, 14:22

Danke, dir trotzdem. Ich werde mir mal die Log's vornehmen und sehen ob ich was entdecken kann.

Jenseits von Gut & Böse
Beiträge: 10679
Registriert: 02.08.2008, 15:06
Wohnort: Hannover/Wuerzburg
Kontaktdaten:

Re: Postgres Problem in VCSA 6.0

Beitragvon irix » 03.01.2017, 16:40

Mal https://kb.vmware.com/kb/2112606 angucken und pruefen ob sich noch die eigentliche Fehlermeldung finden laesst.

Gruss
Joerg


Zurück zu „vCenter / VMware VirtualCenter“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast