Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Linux startet von VmWare für Windows aus nicht

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 2
Registriert: 22.11.2004, 10:49

Linux startet von VmWare für Windows aus nicht

Beitragvon Rio » 22.11.2004, 11:08

Also, zunächst mal funktioniert der Linuxstart vom Bootmanager aus problemlos. :D
Was eben nicht funktioniert ist das Starten von Linux über VMware für Windows (v4.5.2-8848). :shock:
Ich komme gerade mal so weit, daß grub gestartet wird. Dieser landet allerdings in der grub-shell.
Wenn ich mir dann die Partitionen mit geometry (hd0) anschaue, fehlen alle oberhalb von 1024 Zylindern. :x
Logisch, daß grub dann Linux nicht starten kann wenn die /boot dort liegt, aber warum startet VMware die Platte im CHS-Modus und nicht im LBA-Modus???
Damit hatte man zuletzt zu MS-Dos Zeiten gekämpft. Inzwischen sollten wir uns doch weiterentwickelt haben, oder??? :evil:

Benutzeravatar
Moderator
Beiträge: 14668
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 22.11.2004, 15:33

Hi
if Kernel = 2.6 then KB 1235
else - poste mal was genaueres

Member
Beiträge: 2
Registriert: 22.11.2004, 10:49

Beitragvon Rio » 23.11.2004, 07:48

Hallo continuum,

also ich habe ein 2.6'er Kernel, aber ich verstehe nicht :oops: was Du mit KB 1235 meinst.

Ansonsten sieht das bei mir so aus:
Partitionierung Platte1 (SCSI)
primar - DOS
primär - Windows
logisch - Daten
logisch - Daten
logisch - Linux Swap (Fedora Core3)
logisch - Linux boot (Fedora Core3)
logisch - Linux root (Fedora Core3)

Im MBR ist der Boot-US als Bootmanager installiert und wie schon erwähnt als Bootloader verwende ich grub.

VMware ist so konfiguriert, daß ich die Platte "PhysicalDrive0" (SCSI0:0) mit individuellen Partitionen ausgegewählt habe (swap,boot,root).

Die grub-shell zeigt mir nach geometry (hd0):

Code: Alles auswählen

drive 0x80: C/H/S = 124/255/63, The number of sectors = 16450560, CHS
Partition num: 0, Filesystem type unknow, partition type 0x2d
Partition num: 1, Filesystem type unknow, partition type 0x2d
Partition num: 4, Filesystem type unknow, partition type 0x2d


Das war's, die restlichen Partitionen zeigt er mir leider nicht an.


Zurück zu „VMware Workstation“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 4 Gäste