Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Probleme mit Samba unter Linux VM

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 11
Registriert: 18.10.2004, 22:36
Wohnort: New York

Probleme mit Samba unter Linux VM

Beitragvon maniac_2k » 20.10.2004, 18:04

Hallo!

Ich versuche nun schon seit Tagen verzweifelt Daten zwischen meinem Host (WinXP) und meinem Guest (Linux, Redhat) auszutauschen.

Auf Anraten in diesem Forum habe ich versucht einen Samba Server in meiner VM aufzusetzen.

Nun kann ich zwar Samba in meiner WinXP Netzwerkumgebung sehen, zugreifen kann ich darauf jedoch nicht.

Ich im Host und im Guest den gleichen Loginnamen (case sensitive gilt doch hierbei nicht, oder?) und das entsprechende Password in Linux mit smbpasswd -a für Samba eingerichtet.

Meine smb.conf habe ich so belassen wie sie war und nur dies hinzugefügt:

[global]
workgroup = WORKGROUP
netbios name = Samba
encrypt passwords = yes

[homes]
read only = no
browseable = no

[transfer]
path = /transfer
browseable = yes

...wobei /transfer ein Verzeichnis in meinem Guest ist.

Wie bekomme ich nun Zugriff auf meinen /transfer Ordner?

Danke im Voraus,

Maniac

Benutzeravatar
Profi
Beiträge: 992
Registriert: 07.08.2003, 09:32

Beitragvon looping » 20.10.2004, 19:20

bei samba ist es wichtig das nicht nur der samba-user berechtigungen für das freigegebene directory hat sondern auch der linux/unix-user.

der parameter browsable nimmt das directory lediglich in die suchlisten auf - du benötigst noch zugriffsberechtigungen für die user oder gäste und musst denen dann auch noch das lesen oder schreiben erlauben das könnte hinterher so aussehen

[transfair]
comment = transfair
path = /transfair
guest ok = yes
readonly = no

erlaubt allen usern und gästen lesend und schreibend auf /transfair zuzugreifen (das funktioniert aber wie gesagt nur dann, wenn die user auf transfair auch schreibberechtigungen haben).

normalerweise solltest du im verzeichnis /etc/samba (oder etc/smb) eine sample.conf finden - die schau dir mal genauer an. ansonsten findest du unter /usr/doc/samba etliches an info. falls dir das alles nicht weiterhilft, kannst du auch swat benutzen (je nach distribution ist swat schon aktiviert oder nicht - dabei ist swat auf alle fälle).

mfg

looping

Member
Beiträge: 11
Registriert: 18.10.2004, 22:36
Wohnort: New York

Beitragvon maniac_2k » 21.10.2004, 00:06

Läuft leider immer noch nicht.

Ich habe mich als root eingeloggt und das Verzeichnis an alle freigegeben (Rechtsklick auf Verzeichnis, und Rechte vergeben, ist doch richtig, oder?)

Geht trotzdem nicht.

Benutzeravatar
Profi
Beiträge: 992
Registriert: 07.08.2003, 09:32

Beitragvon looping » 21.10.2004, 09:14

mhhh - ich mach das immer auf konsole:

# chmod 0777 /transfair

hast du samba mal mit

# testparm

geprüft? kannst du als user auf userverzeichnise zugreifen oder auf überhaupt irgendein verzeichnis?

mfg

looping

Member
Beiträge: 11
Registriert: 18.10.2004, 22:36
Wohnort: New York

It's magic - Es läuft

Beitragvon maniac_2k » 22.10.2004, 22:22

Mir ist nicht wirklich klar warum, aber es läuft nun.

Ich habe noch ein Samba Tutorial im Netz gefunden, und genau das gemacht, was die gesagt haben. Und jetzt läuft's.

Vielleicht lag es daran, dass man die Rechte auf die Verzeichnisse mit chmod und nicht über das Persmissions Tab de Verzeichnisses vergeben muss.

Vielleicht lag es auch daran, dass ich eine neue VM hochgezogen habe, wo dieses mal die Netzwerkanbindung funktioniert.

Ich weiß es nicht. Jedenfalls DANKE für Deine Bemühungen. Ich habe auf jeden Fall was gelernt :-)

Gruß

Maniac


Zurück zu „VMware Workstation“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste