Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

VM 4.2.1 an Suse 9.1 x86_64 USB unter windows xp pro

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 9
Registriert: 07.07.2004, 20:46
Wohnort: Schweiz

VM 4.2.1 an Suse 9.1 x86_64 USB unter windows xp pro

Beitragvon rabadag » 07.07.2004, 22:54

Hi Forum...

Leider hat ich mit der suche nach einer Lösung meines Problehms
Weder in Google noch in den Foren erfolg.

So hoffe ich, das Ihr mir weiterhelfen könnt.

System Angben
Mainbord: Asus K8V SE Delux
Prozzi: Amd64 300+
Memory 3 x 512MB Kingston
OS: Suse Linux 9.1 x86_64
VM: 4.2.1
VM Patsh: vmware-any-any-update75.tar.gz
Virtual PC: Windows Xp Pro Sp1 + all updats

Broblehm Beschreib.

Meine Virtuelle maschine lauft einwandfrei auser das der USB nicht geht. Ich versuche meine DSS Syncstation vom Sony Ericson Handy P900 mit dem Virtuellem PC Win Xp zu verbinden.

In der VMware unter VM --> USB erscheint auch das Entsprechende Gerät das auch richtig von suse erkannt wurde.

Sobald ich versuche den usb zu verbinden meint XP
"unbekanntes Gerät"
Der versuch den dss usb Treiber zu installiren schlegt fehl.

Das selbe erhalte ich auch wenn ich eine Logitech Camara verbinden will.

Im Geräte Manager von Xp erscheint unter USB nur "unbekanntes Gerät".

Was kann ich hier tun. ??????????

Benutzeravatar
Moderator
Beiträge: 14670
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 07.07.2004, 23:08

USB2?

Member
Beiträge: 9
Registriert: 07.07.2004, 20:46
Wohnort: Schweiz

Beitragvon rabadag » 07.07.2004, 23:12

Ja ich denke schon, das mein Mainbord USB2 Ist,
Im Bios ist aber USB 1.1 Compatible aktiviert.

Benutzeravatar
Moderator
Beiträge: 14670
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 07.07.2004, 23:38

Deine USB-Geraete muessen ausdruecklich fuer den USB 1.1 Kompatibilitaetsmodus geeignet sein ... dass funktioniert leider laengst nicht in allen Faellen.

Member
Beiträge: 9
Registriert: 07.07.2004, 20:46
Wohnort: Schweiz

Beitragvon rabadag » 07.07.2004, 23:43

All Meine Geräte sind USB 1.1 Compatible.
Die Logitech cam selbst ist eine USB 1.1
das DSS Syncstation von P900 USB 2.0 und USB 1.1 Compatible.

Was kann ich den machen. Unter Suse werden die Geräte alle bestens erkannt.

Member
Beiträge: 79
Registriert: 22.04.2004, 13:32

Re: VM 4.2.1 an Suse 9.1 x86_64 USB unter windows xp pro

Beitragvon zaptac » 08.07.2004, 08:10

Hi,

rabadag hat geschrieben:OS: Suse Linux 9.1 x86_64
VM: 4.2.1
VM Patsh: vmware-any-any-update75.tar.gz
Virtual PC: Windows Xp Pro Sp1 + all updats
...

Im Geräte Manager von Xp erscheint unter USB nur "unbekanntes Gerät".

Was kann ich hier tun. ??????????


Ich denke: nix (bzw. warten auf neuere Kernel)

Zitat von http://www.vmware.com/community/thread.jspa?forumID=19&threadID=6044&messageID=39896#39896:

petr hat geschrieben:USB does not work on 64bit hosts. Your Linux kernel does not allow 32bit applications to access USB devices, and so vmware-vmx (which is 32bit app) cannot access them. There is no simple workaround.


Zaptac

Member
Beiträge: 9
Registriert: 07.07.2004, 20:46
Wohnort: Schweiz

Beitragvon rabadag » 08.07.2004, 08:45

Hallo zaptac
Also in dem
http://www.vmware.com/community/thread.jspa?forumID=19&threadID=6044&messageID=39896#39896
USB does not work on 64bit hosts. Your Linux kernel does not allow 32bit applications to access USB devices, and so vmware-vmx (which is 32bit app) cannot access them. There is no simple workaround.

Visit /proc/bus/usb. If it contains file 'devices', it should work. But on your system it probably contains 'devices-please_use_sysfs_instead'. Go and complain to your vendor (i.e. SuSE) that they unilateraly changed published kernel interface.

AFAIK latest SuSE updates (2.6.6 kernels) have reverted this stupidity.


Also wenn mich mein englisch nicht im stich lässt sool das heisen das eine 64 bit maschine keine 32 bit vmware unterstütz und das liegt an der VM Version ?

Der zweite Thert verstehe ich nicht ganz,

Member
Beiträge: 79
Registriert: 22.04.2004, 13:32

Beitragvon zaptac » 08.07.2004, 10:37

Hi,

rabadag hat geschrieben:Also wenn mich mein englisch nicht im stich lässt sool das heisen das eine 64 bit maschine keine 32 bit vmware unterstütz und das liegt an der VM Version ?


Nicht ganz, seit 4.3.2 wird x86_64 als Hostsystem experimentell unterstützt. Meiner Erfahrung nach funktioniert das auch ganz gut.
Nur gibt es scheinbar eine Einschränkung durch den Linuxkernel, dass 32Bit Anwendungen (und damit eben auch VMware) keinen Zugriff auf USB-Geräte bekommen.

Du kannst also entweder
1) warten bis das Problem im Kernel gefixed wird
2) warten bis VMware einen Workaround findet
3) ein 32Bit Betriebssystem als Host installieren

Zaptac

PS: Schau dich da mal um: http://www.vmware.com/community/search!execute.jspa?forumID=19&forceEmptySearch=true&q=x86_64&objID=f19&dateRange=all&userID=&numResults=30

Member
Beiträge: 9
Registriert: 07.07.2004, 20:46
Wohnort: Schweiz

Beitragvon rabadag » 08.07.2004, 11:13

Na dann bleib mir nichts anderes übrg als zu warten bis ein kernel kommt der dies händeln kann, oder VM eine neue version rausbringt.

ist den in disem fall schon was in aussicht ?


Zurück zu „VMware Workstation“

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 1 Gast