Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

Wie kann ich auf beschädigte Guestsysteme zugreifen?

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 15
Registriert: 15.03.2004, 10:46

Wie kann ich auf beschädigte Guestsysteme zugreifen?

Beitragvon Roadrunner » 26.04.2004, 13:06

Hi @all
Ich habe mehrere 3er Boxen, die XP installiert haben, Host ist ebenfalls XP.
Ich bekommen die Fehlermeldung beim power on:

Unable to open the disk 'c.vmdk'.
Failed to configure disk ide0:0. The virtual machine cannot be powered on with an unconfigured disk.

Die Pfade stimmen alle. folgendes ist im Log zu finden:


*****
Apr 26 12:55:04: vmx| DISK: Treating disk 'c.vmdk' as persistent
Apr 26 12:55:04: vmx| DISK: OPEN ide:0:0 'c.vmdk' persistent R[]
Apr 26 12:55:05: vmx| DISKLIB-LEGCHK: There is a hole of 323 sectors after grain [6][431]
Apr 26 12:55:05: vmx| DISKLIB-LEGCHK: Found 1 hole
Apr 26 12:55:05: vmx| DISKLIB-SPARSE: "c.vmdk" : failed to open (14): Disk needs repair.
Apr 26 12:55:05: vmx| DISKLIB-DSCPTR: : "c.vmdk" : Failed to open first BigCOWMember.
Apr 26 12:55:05: vmx| DISKLIB-LINK : "c.vmdk" : failed to open (The specified virtual disk needs repair.).
Apr 26 12:55:05: vmx| DISKLIB-CHAIN : "c.vmdk" : failed to open (The specified virtual disk needs repair.).
Apr 26 12:55:05: vmx| DISKLIB-LIB : Failed to open 'c.vmdk' with flags 0xa (The specified virtual disk needs repair.).
Apr 26 12:55:05: vmx| DISKLIB-LEGCHK: There is a hole of 323 sectors after grain [6][431]
Apr 26 12:55:05: vmx| DISKLIB-LEGCHK: Found 1 hole
Apr 26 12:55:06: vmx| DISKLIB-LEGCHK: There is a hole of 2235 sectors after grain [17][249]
Apr 26 12:55:06: vmx| DISKLIB-LEGCHK: Found 1 hole
Apr 26 12:55:06: vmx| DISKLIB-LEGCHK: There is a hole of 3975 sectors after grain [0][11]
Apr 26 12:55:06: vmx| DISKLIB-LEGCHK: Found 1 hole
Apr 26 12:55:06: vmx| DISKLIB-LEGCHK: Unable to fix internal holes. Please run defragment.
Apr 26 12:55:06: vmx| DISKLIB-LEGCHK: Unable to fix internal holes. Please run defragment.
Apr 26 12:55:06: vmx| DISKLIB-LEGCHK: Unable to fix internal holes. Please run defragment.
Apr 26 12:55:07: vmx| DISKLIB-LEGCHK: There is a hole of 323 sectors after grain [6][431]
Apr 26 12:55:07: vmx| DISKLIB-LEGCHK: Found 1 hole
Apr 26 12:55:07: vmx| DISKLIB-SPARSE: "c.vmdk" : failed to open (14): Disk needs repair.
Apr 26 12:55:07: vmx| DISKLIB-DSCPTR: : "c.vmdk" : Failed to open first BigCOWMember.
Apr 26 12:55:07: vmx| DISKLIB-LINK : "c.vmdk" : failed to open (The specified virtual disk needs repair.).
Apr 26 12:55:07: vmx| DISKLIB-CHAIN : "c.vmdk" : failed to open (The specified virtual disk needs repair.).
Apr 26 12:55:07: vmx| DISKLIB-LIB : Failed to open 'c.vmdk' with flags 0xa (The specified virtual disk needs repair.).
Apr 26 12:55:07: vmx| DISK: Failed to open disk 'c.vmdk' : The specified virtual disk needs repair. (14) 5867
Apr 26 12:55:07: vmx| Msg_Post: Error
Apr 26 12:55:07: vmx| [msg.disk.noBackEnd] Unable to open the disk 'c.vmdk'.
Apr 26 12:55:07: vmx| [msg.disk.notConfigured2] Failed to configure disk ide0:0. The virtual machine cannot be powered on with an unconfigured disk.

***

Ich kann aber auch keinen defrag machen, da kommt die Fehlermeldung:
The specified virtual disk needs repair.

Mit XP boot CD ....geht auch net, denn ich kann die Box ja net starten!!
Ich kann diese Box auch nicht mit dem VMware DiskMount Utility als Laufwerk ins Host XP mounten. da kommt ebenfalls der Hinweis dass die defekt ist.

es ist hierbei auch unerheblich, welche Version und build der 4er ich verwende.

Wer kennt das, oder noch besser, wer kennt ne lösung.

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 26.04.2004, 15:29

Hi
das sieht nicht gut aus!
Als erstes lass mal auf dem Host chkdsk /F /R /X laufen.
Was hast du fuer ein Defragmentierungs-tool? Wenn du nur das XP-eigene hast - schlecht - wenn du OO-defrag oder Disk-keeper hast lass nach dem Checkdisk ordentlich defragmentieren.
Ersatzweise - wenn du eine freie Partition zur Verfuegung hast kopier die einzelnen Teile per cmd mit copy nacheinander von Hand an die neue Stelle. Dann besorg dir das diskmount-tool von Ken Kato. Vielleicht hast du damit mehr Glueck.
Wenn alles nichts hilft, bleibt als letzte Moeglichkeit ein Hexdump auf eine leere Festplatte und ein anschliessendes Abgrasen mit Forensic-tools.

Hattest du Diskcontroller- oder NTFS- Fehler im Log des Hosts?

Wenn die Daten sehr wichtig sind - dann schick mir mal die ersten paar hundert KBs von den einzelnen Disks per e-mail und mach ein ghost oder sonstiges Diskimage von der betreffenden Partition.
Jede Cowdisk hat ein paar Zeilen Header ganz vorne - vielleicht kann man da noch was machen.
Schreibe nichts mehr auf die Partition ehe du nicht chkdsk /F /R /X ausgefuehrt hast.

Continuum

Member
Beiträge: 15
Registriert: 15.03.2004, 10:46

Zusätzliche Informationen

Beitragvon Roadrunner » 27.04.2004, 09:53

Hi auch,
erst mal Danke für deine schnelle Antwort. Ich hab ne wichtige Information vergessen hier zu schreiben:
Diese Boxen wurden ja ursprünglich mit der Version 3 erstellt, dort sind diese auch lauffähig. D. h. wenn ich diese Box mit 3.2 build 2230 starte klappt alles!! Aber keine Version 4 egal welcher build kann diese Boxen starten. Ich habe es auch mit den builds versucht, die du bereits in einem anderen Posting beschrieben hast. Bei mir ist das der anscheinlich der selbe Fehler wie bei Thomas.
Der Host hat keine Fehler auf dem Dateisystem, auch im Log sind keine gemeldet. OO defrag wurde ausgeführt. Alles kein Erfolg..
Wo gibts das andere Diskmount Tool?
*ratlosschau*

*grins*

Roadi

Member
Beiträge: 15
Registriert: 15.03.2004, 10:46

Disktool auch erfolglos

Beitragvon Roadrunner » 27.04.2004, 10:13

Klappt auch nicht, bricht mit einer Fehlermeldung ab:
'D:\VMS\W2k CatClient W7VV-VPPD902575\c-02.vmdk' Timestamps in the header does not match (0x76faf787 <> 0x76faf788).
'D:\VMS\W2k CatClient W7VV-VPPD902575\c-02.vmdk' Unknown virtual hardware version.> 3
'D:\VMS\W2k CatClient W7VV-VPPD902575\c-03.vmdk' Timestamps in the header does not match (0x76faf787 <> 0x76faf788).
'D:\VMS\W2k CatClient W7VV-VPPD902575\c-03.vmdk' Unknown virtual hardware version.> 3
usw.

General flags mismatch.
D:\VMS\W2k CatClient W7VV-VPPD902575\c.vmdk -> 0x0000001f
D:\VMS\W2k CatClient W7VV-VPPD902575\c-02.vmdk -> 0x0000001b
Failed to open the virtual disk image.
******
Allerdings kann ich diese Box öffnen mit ner 3er...also kann die Hardware nicht grösser 3 sein...
seltsam seltsam.. ich probier da nochmal weiter rum.. wenn ich was rausfinde meld ich das hier wieder.
Roadi

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 27.04.2004, 19:08

Hi

Ken Katos VMware-seite: http://chitchat.at.infoseek.co.jp/vmware/

Das war mir schon klar, dass die Disks von WS3/GSX2.5 kamen - WS4 arbeitet ja nicht mehr mit Kuehen - jedenfalls nicht als Festplatten.

Aber das die Disks in WS3 problemlos laufen und in WS 4 Loecher haben sollen - sehr merkwuerdig. Welche 4er Version meinst du eigentlich genau?
Ich habe bei mir ein paar Maschinen auf geteilten Cowdisks die in 7568 problemlos laufen. Ich kann mit diesen Disks einen Tag auf 7568 und den naechsten auf WS3 arbeiten - Das sind allerdings GSX-Cowdisks - ich bin mir aber eigentlich sicher, dass zwischen GSX und WS3 Kuehen kein Unterschied besteht.

Apropo Hardwareversion: In den VMX/CFG Dateien werden die Hardwareversionen etwas anders vergeben als im VMwareversionsnamen.

Hardwareversion 1: WS2 und GSX1 - die Disks hatten die extension .dsk
Hardwareversion 2: WS3 und GSX 2.x
Hardwareversion 3: WS4, WS4.5 und GSX 3

Falls du Lust hast schick mir mal eine Dos-bootfaehige geteilte Cowdisk von Build 2230. Ich moechte mal ausprobieren ob die in 7568 laeuft.
(gezippt sollte das nicht groesser sein als ein paar MB)

Gruss

Ulli

Member
Beiträge: 15
Registriert: 15.03.2004, 10:46

Dos geht

Beitragvon Roadrunner » 28.04.2004, 10:26

Hi,
hmmmmmmm Dos funktioniert, das hab ich getestet, win 9x funktioniert auch, lediglich XP oder 2k mit NTFS geht anscheinend net, da tritt immer der fehler auf, sobald versucht wird, auf die Platte zuzugreifen. Eine neu angelegte Box kann XP drauf installieren, nach dem Neustart ist die Box nicht mehr anfassbar, eine Installations über Windows PE kann sofort nicht auf die Platte zugreifen.
XP Media Center, das ja eigentlich ein XP PRof ist, kann darauf zugreifen.
allerdings wurde diese Box neu unter R4 7568 erstellt.
Harware version in dieser Box ist: virtualHW.version = "2"
Very strange...


Zurück zu „VMware Workstation“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste