Das Forum wurde aktualisiert. Wurde höchste Zeit. Wenn etwas nicht funktioniert, bitte gerne hier jederzeit melden.
(Das "alte Design" kommt wieder, wird ne Weile brauchen!)

VMware 4.5.1 automatische Power off

Hilfe bei Problemen mit der Installation und Benutzung der VMware Workstation.

Moderatoren: irix, stefan.becker, continuum, Dayworker, Tschoergez

Member
Beiträge: 2
Registriert: 15.04.2004, 19:54

VMware 4.5.1 automatische Power off

Beitragvon durzt » 15.04.2004, 20:11

Hallo Leute,

folgendes Problem.

Ich nutze Debian Woody mit Kernel 2.4.24 darauf läuft derzeit Vmware 4.5.1 mit Windows XP Home Edition als Guest OS.

Ich mache mit dem System einige Messungen welche vom Linuxsystem gesteuert werden. Sprich Linux fährt die VMware hoch, dann VMware Windows und im Windows werde via Autostart einige Perlscripte started anschließend fährt beendet sich Windows sowie die Vmware. Dann beginnt wieder alles von vorne.

Gestarted wird das ganze mit

Code: Alles auswählen

 vmware -x -q configfile.cfg



Unter VMware 4.01 lief das alles ohne Probleme aber nach dem Update auf die 4.5.1 bekomme ich immer ein Fenster wenn sich die VMWare schließen soll :

"You have just powered off the virtual machine. What would you like to do?
- power off
- take snapshot
- revert to snapshot"

Kann mir jemand vielleicht sagen wie ich diese Abfrage umgehen und als Default "power off" eingestellt werden kann und diese Abfrage nicht mehr erscheint und somit keine Benutzerinteraktion mehr nötig ist?

Freue mich auf Eure Antworten.

Danke und Gruss
Patrick

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 15.04.2004, 21:47

Hi
wenn du die VM das naechste Mal runter faehrst notier dir die Uhrzeit wenn die Abfrage kommt.
Dann guck mal ins VMware-log. Such nach der Zeit.
Du findest dann vielleicht einen Eintrag wie diesen
hint.vmxvmdb.poweronLegacyUndoable = FALSE
oder irgendetwas was sich erkennbar auf die Abfrage bezieht.

Merk dir den Eintrag und such in der preferences.ini (Windows-name, wahrscheinlich aber auch bei Linux) in /home/username/.vmware ob du etwas entsprechendes findest.
Wenn du Glueck hast ergibt sich das passende Parameter aus dem Zusammenhang.
Wenn du nichts findest - dann poste mal das log und die preferences.ini

Ulli

Member
Beiträge: 2
Registriert: 15.04.2004, 19:54

Beitragvon durzt » 15.04.2004, 22:36

Hallo Ulli,

erstmal vielen Dank für Deinen Tip, ich habe auch im LOG was gefunden
[code]
Apr 15 22:09:42: vmx| Msg_Question:
Apr 15 22:09:42: vmx| [msg.vmxvmdb.promptOnPoweredOff] You have just powered off the virtual machine. What would you like to do?
Apr 15 22:09:42: vmx|
Apr 15 22:09:42: vmx| Here is the mapping of the snapshot to legacy disk mode terms:
Apr 15 22:09:42: vmx| Just Power Off => Keep
Apr 15 22:09:42: vmx| Take Snapshot => Commit Disks
Apr 15 22:09:42: vmx| Revert to Snapshot => Discard
Apr 15 22:09:42: vmx| ----------------------------------------
Apr 15 22:09:49: vmx| Msg_Question: msg.vmxvmdb.promptOnPoweredOff reply=0
Apr 15 22:09:49: vmx| VMXVmdbHandlePoweredOff: Keep-on-poweroff chosen.
Apr 15 22:09:50: vmx| vmdbPipe_Streams Couldn't read: OVL_STATUS_EOF
Apr 15 22:09:50: vmx| VMX idle exit
[code]

Allerdings habe ich nicht passendes im preferences File gefunden:
[code]
# DO NOT EDIT THIS FILE.
# This file is automatically generated and maintained by VMware products.
#
# If you must edit this file in spite of our recommendations, please first
# make sure that no VMware virtual machines are running.
prefvmx.mru.config = "/vmware/winXPHome/winXPHome.cfg:/vmware/golden-client/winXPHome/winXPHome.cfg:/vmware/golden-client-ab
nahmetest/winXPHome/winXPHome.cfg:/vmware/winXPHome/winXPHome.cfg.persistent.in:/var/lib/vmware/win98/win98.cfg:"
hint.svgax.dgaNoAccel = "FALSE"
hint.gui.reset = "FALSE"
hint.gui.poweroff = "TRUE"
pref.toolbar = "FALSE"
pref.statusBar = "FALSE"
hint.gui.exit = "TRUE"
hint.mks.fullscreen = "FALSE"
hint.guestos.xp = "FALSE"
hint.xkeymap.notLocal = "FALSE"
hint.mks.notLocal = "FALSE"
hint.hostlinux.rtcopen = "FALSE"
hint.monitorevent.halt = "FALSE"
hint.tools.toolsImage = "FALSE"
pref.autoFit = "FALSE"
hint.vnet.randomAddr = "FALSE"
hint.cpuid.unknownfeature = "FALSE"
prefvmx.mru.suspended = ""
pref.syncTime = "TRUE"
pref.motionScroll = "FALSE"
pref.placement.right = "964"
pref.placement.bottom = "460"
pref.openedVM0.present = "TRUE"
pref.openedVM0.file = "/vmware/winXPHome/winXPHome.cfg"
pref.openedVM.maxNum = "3"
hint.vmxvmdb.poweronLegacyNonpersistent = "FALSE"
pref.view.favorites = "FALSE"
pref.view.statusBar = "FALSE"
pref.view.tabs = "FALSE"
pref.view.toolbars = "FALSE"
pref.placement.left = "303"
pref.placement.top = "0"
pref.view.navBar.type = "favorites"
pref.openedVM1.present = "TRUE"
pref.openedVM1.path = "/vm/|235b6bfdded94b1f7c/"
pref.openedVM1.file = "/vmware/winXPHome/winXPHome.cfg"
pref.openedVM1.name = "XPHome"
pref.openedVM1.dest = "/host2/|234fda1e06412f3570/"
pref.tip.startup = "FALSE"
pref.tip.index = "1"
pref.currentVM = "/vm/|2390b6267bf08a57db/"
hint.vmxvmdb.poweronLegacyUndoable = "FALSE"
pref.openedVM2.present = "TRUE"
pref.openedVM2.path = "/vm/|2390b6267bf08a57db/"
pref.openedVM2.file = "/vmware/winXPHome/winXPHome.vmx"
pref.openedVM2.name = "winXPHome"
pref.openedVM2.dest = "/host2/|234fda1e06412f3570/"
[/code]

Siehtst du vielleicht etwas?

Danke und viele Grüße
Patrick

Benutzeravatar
Moderator
Beiträge: 14663
Registriert: 09.08.2003, 05:41
Wohnort: sauerland
Kontaktdaten:

Beitragvon continuum » 15.04.2004, 23:20

Hi
bei Windows kann das unter Settings - Options - Snapshot eingestellt werden. Gehts das bei Linux nicht auch?

Moeglichkeiten sind
Just power off
Revert to Snapshot
Update the snapshot
Ask me

Wenn das im Log als message auftaucht kann man glaube ich so einfach nichts machen.

Ulli


Zurück zu „VMware Workstation“

Wer ist online?

Mitglieder in diesem Forum: Google [Bot] und 1 Gast